**Major Outage**

October 26, Fri
Affected Service: MxM Core Site Services Profiles, Notifications & Messaging Photos Video Library of MxM
  • Investigating
    Due to unforeseen errors with the vendor hosting MxM, we are now undergoing extended maintenance. A significant amount of data was lost, but ALL registrations were recovered.

    As soon as MxM is back online, this page will redirect as normal to the site and recovery initiatives will begin.

    We sincerely thank our 700+ members and counting for their patience, and for believing in our mission - even through our failures.

    ~ loganxs, Founder

    04:26, Oct 24 CST
  • Resolved
    MxM has been fully restored. Some data loss has occurred, but measures have been taken to ensure this doesn’t happen again - and so if it does, we will be fully prepared.

    18:35, Oct 26 CST
Back to current status