Mail Server Degraded

April 25, Sat
Affected Service: Email Notifications System
  • Fixing
    We can't catch a break, can we? Unexpected issues with recovery impacted how mail services recognize us globally. To prevent them from marking us as spam, we're stopping all outbound mail traffic for the time being - while we sort it out. 2FA (Two-Factor Authentication), password resets, and all email notification-based features have been temporarily disabled. We should be able to lift this in a couple days' time. Please don't hate us.

    23:18, Apr 20 CDT
  • Monitoring
    We’ve reactivated email notifications, and they can now be configured again in Settings > Notifications on MxM. We’re monitoring to make sure the blacklist situation is sorted. Our signature should be propagating normally now.

    09:59, Apr 25 CDT
  • Resolved
    Password resets, unusual login detection, 2FA (Two-factor Authentication), as well as all mail-powered functionality restored. Resolving. Woo!

    18:56, Apr 25 CDT
Back to current status