Unexpected ISP-Level Outage

May 03, Sun
Affected Service: MxM Network (v4) Content Management System (CMS) Geolocation/Maps Service Email Notifications System Push Notifications System MxM Videonet The Archive Cloud Help and Support System
  • Identified
    MxM is offline due to a network failure beyond our server. Several sites beyond ours are impacted as well by this outage. We’ll notify when this has been resolved. Thanks for being a member.

    08:35, May 03 CDT
  • Resolved
    Network restored. That was quick.

    08:36, May 03 CDT
Back to current status