Videonet Sign-In Degraded

February 20, Sat
Affected Service: MxM Videonet
  • Identified
    The only way to sign into Videonet (https://mxmnext.con) is by authenticating with an active MxM Network (https://mxmifc.com) membership. This authentication process is failing, and we’re investigating why. In the meantime, if you’re already signed into Videonet, we recommend NOT signing out of it until we’ve fixed the issue.

    07:24, Feb 20 CDT
  • Resolved
    Fixed! Signing into Videonet (https://mxmnext.com) will work now.

    12:36, Feb 20 CDT
Back to current status